Mindjet
     
 
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Mindjet Connect Error: Unable to connect to server

Applies to: MindManager 7.2 or greater (with Mindjet Connect)
 

Symptom

MindManager tries to connect to Mindjet Connect, and one of the following (or similar) error messages show up:

·         MindManager can’t reach the Mindjet Connect server for this account.

·         Unable to connect to server https://...

·         Cannot find server https://…

·         A connection attempt failed because the connected party did not properly respond…

Cause

Mindjet Connect uses HTTPS protocol using standard TCP via port 443. MindManager does not have proxy or proxy authentication settings. Instead MindManager reads the Internet Explorer proxy settings and relies on these settings to handle proxy servers. Usually the above error messages occur if either the proxy server cannot be reached, or requires authentication or a firewall is blocking MindManager attempt to connect to the remote server. In some rare cases if the Mindjet.com Account hasn’t been registered properly, this can also be the reason for MindManager to be unable to connect to Mindjet Connect.

Resolution

Please follow this checklist to figure out whether a connection issue is due to a not properly registered account or a proxy server or firewall issue.

1. Check if you can successfully login to Mindjet.com Account

Follow these steps:

If you can

·         Access the Mindjet Connect Account Management Center and

·         See your Accounts under “Manage Accounts” and

·         Start the MindManager Web client successfully

It means that your Mindjet Connect Account is registered properly.

2. Check if your identity information is available from the provisioning server

Follow these steps:

·         Open Internet Explorer and go to:  https://gc.mindjet.com/GetIdentityInformation.aspx

·         When prompted to enter account information, use the same credentials you used to sign up for Mindjet Connect (email address + password).

·         After login, you will see some XML text with your Name, Email etc.

If you see all of the above this means:

·         You have a valid MJC account.

·         You can reach the MJC provisioning sign-in server

3. Verify if the registry provides the correct URL for the provisioning server

Follow these steps:

·         Go to Start - Run and type regedit, then navigate to the following registry key:

·      [HKEY_CURRENT_USER\Software\Mindjet\MindManager\7\Connect Options.B4.1]

·         See if the GlobalCatalogUrl entry matches below URL:

·       "GlobalCatalogUrl"=https://gc.mindjet.com/GetIdentityInformation.aspx

If not, please correct the value.

4. Check your Firewall settings

Note: You may need to check with your IT department to figure out if your environment is using a firewall and to check and optimize the settings for usage with Mindjet Connect.

Try the following steps:

·         Temporarily turn off filtering and “allow all”

·         If MindManager then connects successfully, it is a firewall issue and you need to optimize your firewall settings.

·         Allow MindManager.exe to connect to the Internet via port 80 and 443

·         Put rules in place to allow access to the hostname

o   gc.mindjet.com (165.193.246.58)

5. Check your Proxy server settings

Note: You may need to check with your IT department to figure out if your environment is using a proxy server and to check and optimize the settings for usage with Mindjet Connect.

Attention: MindManager reads the Internet Explorer proxy settings and relies on these settings to handle proxy servers. Mindjet Connect requests are sent anonymously and MindManager does not support proxy server authentication. That means it does not subsequently respond to proxy service’s request for authentication (HTTP Error 407 - Proxy authentication required) with an authenticated request.

Try the following steps:

·         Put rules in place which allow MindManager anonymous access to the proxy server

·         Put rules in place to allow access to the hostname

o   gc.mindjet.com (165.193.246.58)

o   and do not require authentication