Mindjet
     
 
.

Slow Performance/High CPU usage while executing MindManager

Applies to: MindManager X5, 6, 7
 
Symptom

MindManager shows slow performance or high CPU usage (in idle mode).

Cause

MindManager's graphic intensive engine as well as the XML format can lead to a higher CPU utilization, specifically when processing larger maps or opening multiple (large) maps at the same time.

Depending on the number of maps opened, number of topics, extensive usage of topic notes, hyperlinks, graphics inside your map MindManager may slow down. A memory usage of 50-100 MB for large maps is common. A higher usage after opening a map is normal for 5-10 seconds while it processes the map contents. How far performance is affected depends on the general performance of your pc system.

Resolution

Following options may improve the MindManager performance:
 
1. Reduce the hardware acceleration for your graphics card

This can be done in your Windows Display properties. Right-click on your desktop or go to Control Panel > Display. On the Settings tab, click Advanced. On the Troubleshooting tab, slide the hardware acceleration to the left. You may wish to experiment with each level to see what works best for your system.
 
2. Remove background images
 
Reduce the amount of background graphics. Do this by right-clicking on the workspace and selecting Background. Press the button remove image to take out any background images that may be using up video memory.

3. Deactivate visual effects

Under Tools > Options > General you find Visual Effects. Switch off all available options.